Início > Programação, Ruby > Mini-curso de Introdução a Linguagem Ruby

Mini-curso de Introdução a Linguagem Ruby

Ontem pude ministrar um mini-curso de introdução à linguagem Ruby para os amigos do mestrado da UFC.
Parabéns à turma pela presença e pela excelente participação durante todo o curso!!!

Os slides do nosso curso estão disponíveis no Slide Share:

A versão ultra atualizada dos slides poderá ser sempre baixada em:
http://dl.dropbox.com/u/1477113/material_didatico/ruby/curso_ruby.odp

A documentação oficial e online do Ruby pode ser consultada em: http://ruby-doc.org/

Já a documentação offline em HTML (RDoc) do Ruby pode ser baixada em:
http://ruby-doc.org/download/ruby-1.8.6-core-rdocs.tgz

Site oficial do Ruby: http://www.ruby-lang.org/pt/

Ruby 1.9.2:
Instalador para Windows: http://rubyforge.org/frs/download.php/72170/rubyinstaller-1.9.2-p0.exe
Documentação completa em formato CHM: http://rubyforge.org/frs/download.php/72161/ruby-1.9.2-p0-doc-chm.7z

Sobre o Ruby 1.9.2:
“O Ruby 1.9.2 é uma versão moderna de Ruby. Dentre as principais características, ele finalmente fecha o gap de performance em comparação a outras linguagens de script como Python e Perl, sendo bem mais competitivo.”
Fonte: http://akitaonrails.com/2010/08/25/semana-de-ruby

Ver também: http://under-linux.org/lancado-ruby-1-9-2-1566/

No Ubuntu 10.04 (Lucid), é possível instalar o pacote ruby1.9.1.
Para usar a versão 1.9.2, podemos compilar a partir do fonte:
ftp://ftp.ruby-lang.org//pub/ruby/1.9/ruby-1.9.2-p0.tar.gz
Ver: http://torqueo.net/installing-ruby-192-and-rails-3-stable-on-ubuntu/

Na versão 10.10 (Maverick) do Ubuntu (lançada em 10/10/10), ao instalar o pacote ruby1.9.1, estaremos na verdade usando a versão 1.9.2:
Package: ruby1.9.1 (1.9.2.0-1) [universe]
Interpreter of object-oriented scripting language Ruby 1.9.2

This package provides version 1.9.2 series of Ruby, which is binary-compatible with the 1.9.1 branch.

Na próxima versão do Easy Rails (http://rubyforge.org/projects/easy-rails/ e http://github.com/regispires/easy-rails), pretendo usar o Ruby 1.9.2 e Rails 3. E realmente gostaria que mais pessoas se integrassem à nossa equipe de desenvolvimento.

Performance do Ruby 1.9 (http://programmingzen.com/2008/12/10/reflections-on-the-ruby-shootout/):

Geometric mean bar chart

Mais informações sobre Ruby em:
https://regispires.wordpress.com/tag/ruby/

Categorias:Programação, Ruby Tags:,
  1. Esmerino
    23/10/2010 às 05:08

    Obrigado professor,por compartilhar os slides

    • regispires
      23/10/2010 às 18:11

      Blz, Esmerino e espero poder compartilhar outros à medida que forem feitos.
      Abraços!

  2. 23/10/2010 às 14:23

    Parabéns Regis, material interessante e massa! E muita força no Easy Rails, espero que a comunidade do Ruby olhe-o com carinho e venha a somar com você no projeto.

    Abraços!

    • regispires
      23/10/2010 às 18:26

      Obrigado, Felipe e parabéns a você por seu trabalho em torno do software livre!!! Sobre o Easy Rails, há mais alguns interessados em ajudar e pretendemos lançar novas versões com algumas novidades interessantes em breve…

  1. No trackbacks yet.

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: