Início > Programação, Ruby, Web > Nova versão do Easy-Rails para Windows

Nova versão do Easy-Rails para Windows

Acabamos de lançar a versão 0.9.7 do Easy-Rails para Windows.Ele foi atualizado para usar o Ruby 1.9.2 e o Rails 3.0.3.
Optamos pela versão 1.9.2 do Ruby por sua melhor performance em relação às versões anteriores.
A partir de agora passamos a usar os binários e a documentação do RubyInstaller.

Além disso, já vem prontinho para acessar SQLite, MySQL e PostgreSQL.
Acesse: http://rubyforge.org/projects/easy-rails/

Também criamos um projeto do Easy-Rails no GitHub com os scripts para geração das versões binárias.

  1. 21/01/2011 às 09:26

    Oi Regis, tudo bem?

    Fala aí qual é a diferença entre o Easy-Rails e o Ruby Installer?

    Abraços

    • regispires
      21/01/2011 às 10:09

      Oi, Lucas! O Easy-Rails é interessante para quem vai usar um computador qualquer, pois não instala nada na máquina, apenas descompacta os arquivos. Além disso, já vem com o Rails e as gems dos bancos livres mais usados, sendo ideal para quem não tem conexão com a Web e quer dar os primeiros passos no Rails. Assim, vejo alguns cenários mais interessantes para o uso dele: demonstrações, cursos ou teste/avaliação do Rails. Outro cenário seria o desenvolvimento em laboratórios, lan-houses, etc.

    • regispires
      21/01/2011 às 10:22

      Lucas,
      Finalmente fiz aqueles scripts de geração do easy-rails que você mesmo sugeriu. Agora está mais fácil atualizar para novas versões de forma automatizada. Os scripts para Linux e Windows estão no github: http://github.com/regispires/easy-rails

  2. 21/01/2011 às 15:23

    Tá massa! =D

    • regispires
      21/01/2011 às 15:54

      Lucas,
      Aceito sugestões e ajuda para melhorar ainda mais os scripts. São nossos!!!

  3. 21/01/2011 às 17:07

    Pelo o que estou vendo já está ótimo!

    O que estamos precisando mais é de um site bonitão, estilo o do Ruby Installer. Uma sugestão seria criar no site uma página para as pessoas baixarem suas próprias versões do Easy-Rails, adicionando ou selecionando as gems que elas usam.

    Ainda não parei pra testar, mas assim que puder fareis uns testes e te mandarei um feedback mais preciso.

  4. Fernando Fabreti
    03/02/2011 às 17:37

    Parabéns amigo! Você facilitou a vida de muita gente!

    Estou usando a versão 0.9.6, o arquivo (bin\use_ruby.bat) deve ser colocado na raiz.
    Para chamá-lo com um duplo-clique e obter uma janela de comando, basta editá-lo e substituir a linha:
    rails -v
    por:
    CMD /K “rails -v”

    • regispires
      03/02/2011 às 17:59

      Oi, Fernando! Obrigado pelo seu comentário. A intenção é realmente facilitar.
      Sobre o script use_ruby.bat ir para o diretório raiz, não é necessário.
      Basta um clique duplo sobre o script ruby_console.bat que já está no diretório raiz.
      O ruby_console.bat já executa o use_ruby.bat.
      Daí uma janela de comando é aberta no diretório rails_apps do easy-rails.
      Entendeu?

  5. 08/05/2011 às 18:38

    Boa noite,

    Como faço para usar a sua nova versão com o xampp? Na documentação fala que é possivel…

    Abraços

    Lucas

    • regispires
      08/05/2011 às 19:27

      Lucas,
      Vejo duas principais finalidades de usar o Easy Rails e o XAMPP juntos.
      1. Como o Easy Rails não vem com o servidor MySQL, podemos usar o MySQL do XAMPP para ser acessado pela aplicação Rails.
      2. Também é possível configurar o Apache do XAMPP para funcionar como proxy de uma aplicação Rails em execução.
      Não sei se consegui ser claro, mas caso tenha mais alguma dúvida é só dizer.

      Abraços,
      Regis.

  1. No trackbacks yet.

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: